Problem Description


Metrics on the Dashboard tab are not displayed on DatafFoundry UI with a mixed content exception on the web browser.


 

For Instance:


The page at ‘https://datafoundry-ui.com’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http:// datafoundry-ui.com:3030/api/v1/engagement/get/jobs/jobStatus?interval_type=all&timeStamp=1593646173&limit=20’

 

Root cause 


This issue occurs if DataFoundry UI is being reached over an HTTPS URL with no SSL properties configured on the edge node. The web browsers might block mixed content or insecure (HTTP) content being loaded into a secure (HTTPS) page.

 

Dashboard metrics are returned through an HTTP GET request if SSL is not configured for NGINX server.

  

Solutions: 

 

1)  To remove the exception and make calls on HTTPS we will need the SSL certificate and key loaded and configured on the edge node instance.

 

2) While using self-signed certificates for SSL, the certificate needs to be imported as a trusted certificate on Google Chrome. If the self-signed certificate is not added as trusted, dashboard will still not load with error “Certificate Verification Failed”

 

For solutions 1 and 2, please refer below link to configure the SSL certificate and key path for NGINX service:  https://docs2x.infoworks.io/admin-and-operations/service-management#secure-services-with-ssl

 

3)If you need to load the the DataFoundry Dashboard using HTTPS URL without any configuration SSL on the edge node, then you would need to change Google Chrome settings to allow mixed content as shown in the below screenshot. 

 


I.         Click the lock or caution icon, then click Site settings.

II.     Scroll to Insecure content, then use the drop-down list to change Block (default) to Allow.

 


 

Applicable Infoworks versions 

 

Infoworks v3.1.x, v2.9.1