Problem Description:


Pipeline preview data does not show data on UI and states error from DT server. Upon looking up interactive.out you might see an error such as below 


Caused by: com.fasterxml.jackson.databind.JsonMappingException: Incompatible Jackson version: 2.9.7


Root Cause

DT service was failing due to an incompatible Jackson version. We added spark jars at the beginning of the dt interactive classpath to fix this issue. 

.



dt_interactive_classpath=/usr/lib/spark/jars/*:/opt/infoworks/lib/extras/dt/*:/opt/infoworks/lib/dt/jars/*:/opt/infoworks/lib/dt/libs/*:/opt/infoworks/lib/dt/interactive/*:/opt/infoworks/dt/udfs/*:/opt/infoworks/bin/tools.jar:/opt/infoworks/lib/mongodb/mongo-java-driver-3.8.0.jar:/opt/infoworks/platform/lib/common/*:/opt/infoworks/platform/bin/notification-common.jar:/opt/infoworks/platform/bin/platform-common.jar:/usr/lib/spark/conf:/usr/lib/spark/jars/*:/usr/lib/hive/conf:/usr/lib/hive/lib/*:`hadoop classpath`



Applicable IWX version

3.3.3 GCP