Problem Description:

Infoworks dashboard is not displaying any data, sample screenshot looks like below,


Root cause:

This happens because the hostname/IP involved in the API call made to fetch the dashboard data is not resolving or it's not referring to infoworks node. In the above screenshot, the hostname in the API call is localhost and it is referring to the client machine, not the infoworks server.


Solution:

To fix this dashboard issue we need to change the value of one config in conf.properties file to server public IP or to fully qualified domain name and restart UI and Nginx services. Steps are mentioned below,

1. Login to infoworks node as infoworks user
2. cd $IW_HOME/conf
3. Change the value of proxy_server_host to public IP or FQDN in conf.properties file(ex: proxy_server_host=10.18.1.24)
4. cd $IW_HOME/bin
5. ./stop.sh ui nginx && ./start.sh ui nginx


Applicable IWX versions:

IWX 3.1.0 onwards