Problem Description:

UI is not loading properly after securing the services with SSL, shows no route definitions found. The sample page looks like the below screenshot,


Root cause:

This happens when infoworks user is not able to access the Nginx temp cache files. We can see the below messages in the error.log of Nginx.

21/07/28 06:18:39 [crit] 349742#0: *217 open() "/opt/infoworks/resources/nginx-portable/proxy_temp/9/00/0000000009" failed (13: Permission denied) while reading upstream, client: 49.204.225.33, server: , request: "GET /app/app.js?hash=3d554bec2f560f58cbcfb150ae6eab55de7cf1f1 HTTP/1.1", upstream: "http://10.18.6.63:3080/app/app.js?hash=3d554bec2f560f58cbcfb150ae6eab55de7cf1f1", host: "34.122.177.206:3000", referrer: "https://34.122.177.206:3000/"


Solution:

In 2 ways we can resolve this issue. 

Solution 1: Recursively changing the user and group permission of NginX temp directory(/opt/infoworks/resources/nginx-portable/proxy_temp) to infoworks user.

chown -R infoworks:infoworks /opt/infoworks/resources/nginx-portable/proxy_temp


Solution 2: We can disable browser cache so that while loading the UI it won't refer to the cache.

In google chrome:

Right click -> inspect -> settings -> check Disable cache(in network section) -> refresh the UI



In Mozilla Firefox:

Right click -> Inspect element -> Customise developer tool -> settings -> Disable http cache(in advanced settings) 

-> refresh the UI




Applicable IWX versions:

IWX 5.0